Alert: SSL Security Breach

Yesterday OpenSSL, an open-source software that's used to encrypt web communications, was breached resulting in a widespread vulnerability codenamed "Heartbleed." D-I routinely uses the OpenSSL technology to secure sensitive online transactions for its clients.

This vulnerability leaves an open door for unsophisticated attackers to retrieve sensitive information during it's transmission to or from our servers. This includes, but is not limited to, usernames, passwords and credit card information.

While we do not believe this breach is an attack on our servers, it does leave a vulnerability that is present in over half of the web. We take security very seriously.

All of our current clients have been reviewed and the recommended security patches have been applied to their accounts.

You can learn more about the Heartbleed vulnerability on the OpenSSL website, or at heartbleed.com.

If you have any further questions or concerns about this breach, please contact us.

  • Security